Resolved
Latencies have remained normal overnight. The issue has been resolved.
Monitoring
Webhook delivery delays have been cleared and processing is back to normal. We’ll continue monitoring to ensure stability.
Identified
We have identified an issue within our notification system which is causing increased lag for webhook sends. We are taking steps now to remediate the issue.