Resolved
We successfully audited our mitigations for the problematic workload and feel good about the stability of our system. We are acting on further mitigations to better detect and prevent similar problems in the future.
Monitoring
We've identified the root cause in our usage system and have performed several mitigations.
We continue to monitor the stability of the system and are working to enact further mitigations to prevent a recurrence of these issues.
Investigating
We have identified an issue within our notification system and api which is causing increased lag. We are taking steps now to remediate the issue.