Resolved
We have monitored the fix overnight and the issue didn't recur.
Monitoring
The fix has been deployed, we will be monitoring overnight.
Identified
We have identified increased latency in our offset notification system. We have identified the issue and are applying a fix.