No components marked as affected
Resolved
We have identified all affected customers from this incident. If you have been impacted, a Metronome representative will reach out.
Monitoring
We have deployed the remaining fix for spend threshold billing configurations. Clients are now fully able to re-enable threshold billing configurations through the API.
Identified
When a previously unsuccessful threshold billing configuration on a contract is re-enabled via the v2/contracts/edit API, the configuration does not get enabled. Re-enabling performed through the frontend is confirmed to be working as expected.
This affects re-enabling attempts via the API since 3/1/2026. We are currently deploying a fix for credit balance threshold configurations, and will fast-follow with a fix for spend threshold configurations.