Resolved
The mitigation is complete. Impact spanned 22:31 - 22:57 UTC.
Identified
Metronome is experiencing an API outage that is primarily affecting retrieval of invoices and contracts. Ingest is not impacted at this time.
Impact began at 22:31 UTC.
We are actively working on the mitigation.